Issue Prescribing

Incident Report for Photon Health

Resolved

Investigating an issue reported with providers being unable to prescribe
Posted Oct 13, 2024 - 15:00 UTC